summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2012-04-17 11:18:25 +0200
committerStef Walter <stef@thewalter.net>2012-04-17 11:20:05 +0200
commit5c8db740a178e417b7afc4bf8acf5e9f475c4e82 (patch)
treea8f37fa2cb5173a020fd3803354a0e90c3a14e95 /Makefile.am
parent2cd970c7719e9e9e4af685d3f8b6e6b4bdcc8929 (diff)
Release 0.4HEADmaster
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 115359a..5536493 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,4 +4,15 @@ SUBDIRS = tools www
EXTRA_DIST = graphics
dist-hook:
- rm -rf `find $(distdir)/ -name .svn`
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generate automatically. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat --date=short ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi