summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2006-01-21 19:20:08 +0000
committerStef Walter <stef@memberwebs.com>2006-01-21 19:20:08 +0000
commit00e5df0f96a713060e5839f80b9b4fa6f562b0c3 (patch)
tree3ecb341887fc241f11aed374b34e6e00f26d7bdb /configure.in
parent428f3570f98224e7fd2ff18e1e199068b3285a5d (diff)
Infrastructure for the C daemons.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..660d9b2
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(rrdui, 0.1, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(rrdui, 0.1)
+
+LDFLAGS="$LDFLAGS -L/usr/local/lib"
+CFLAGS="$CFLAGS -I/usr/local/include"
+
+AC_CONFIG_SRCDIR([src/rrdcollectd.c])
+AM_CONFIG_HEADER([config.h])
+
+# Debug mode
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Compile binaries in debug mode]))
+
+if test "$enable_debug" = "yes"; then
+ CFLAGS="$CFLAGS -g -O0"
+ AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
+ echo "enabling debug compile mode"
+fi
+
+dnl Check for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_C_INLINE
+
+dnl Check for header files.
+AC_HEADER_STDC
+dnl TODO: AC_CHECK_HEADERS
+dnl TODO: Check for libbsnmpclient
+
+AC_MSG_RESULT()
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT