summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 0 insertions, 42 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 3facecc..0000000
--- a/configure.in
+++ /dev/null
@@ -1,42 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(rrdui, 0.4, stef@thewalter.net)
-AM_INIT_AUTOMAKE(rrdui, 0.4)
-
-LDFLAGS="$LDFLAGS -L/usr/local/lib"
-CFLAGS="$CFLAGS -I/usr/local/include"
-
-AC_CONFIG_SRCDIR([tools/rrdui-cgi.c])
-AM_CONFIG_HEADER([config.h])
-
-CFLAGS="$CFLAGS -Wall"
-
-# Debug mode
-AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug],
- [Compile binaries in debug mode]))
-
-if test "$enable_debug" = "yes"; then
- CFLAGS="$CFLAGS -g -O0"
- AC_DEFINE_UNQUOTED(_DEBUG, 1, [In debug mode])
- echo "enabling debug compile mode"
-fi
-
-dnl Check for programs.
-AC_PROG_CC
-AC_PROG_INSTALL
-AC_PROG_RANLIB
-
-dnl Checks for libraries
-AC_CHECK_LIB(rrd, rrd_update, ,
- [echo "ERROR: librrd not found."; exit 1])
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_C_INLINE
-
-AC_HEADER_STDC
-
-AC_MSG_RESULT()
-
-AC_CONFIG_FILES([Makefile tools/Makefile www/Makefile])
-AC_OUTPUT