summaryrefslogtreecommitdiff
path: root/libs/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2004-07-29 19:10:50 +0000
committerStef Walter <stef@memberwebs.com>2004-07-29 19:10:50 +0000
commit85dfb472da8d1270e78f25b7d6a0daaf025cebed (patch)
tree424812e06bc7afe8027e65692ebf13cce38eb2fb /libs/Makefile.am
parent8144f0cd3696efab31058f4f2c7e58d157cea826 (diff)
- Added the DOMC library and get it to build with everything else
Diffstat (limited to 'libs/Makefile.am')
-rw-r--r--libs/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libs/Makefile.am b/libs/Makefile.am
new file mode 100644
index 0000000..6a8c88d
--- /dev/null
+++ b/libs/Makefile.am
@@ -0,0 +1,24 @@
+
+EXTRA_DIST = files prepare-libraries.sh libmba domc
+
+# We have to take over here and do all these things ourselves
+# as the libraries' make files aren't automake compatible
+
+all:
+ chmod -R u+rw $(srcdir)/libmba
+ $(MAKE) -C $(srcdir)/libmba $@
+ chmod -R u+rw $(srcdir)/domc
+ $(MAKE) -C $(srcdir)/domc $@
+
+clean:
+ chmod -R u+rw $(srcdir)/libmba
+ $(MAKE) -C $(srcdir)/libmba $@
+ chmod -R u+rw $(srcdir)/domc
+ $(MAKE) -C $(srcdir)/domc $@
+
+install:
+
+
+dist-hook: clean
+ rm -rf `find $(distdir)/ -name CVS`
+