summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 3 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 21f472a..6a14097 100644
--- a/configure.in
+++ b/configure.in
@@ -36,8 +36,8 @@ dnl Nate Nielsen <nielsen@memberwebs.com>
dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(rtfx, 0.9.3, nielsen@memberwebs.com)
-AM_INIT_AUTOMAKE(rtfx, 0.9.3)
+AC_INIT(rtfx, 0.9.4, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(rtfx, 0.9.4)
LDFLAGS="$LDFLAGS -L/usr/local/lib"
CPPFLAGS="$CPPFLAGS -I/usr/local/include"
@@ -66,22 +66,6 @@ if test "$enable_debug" = "yes"; then
echo "enabling debug compile mode"
fi
-# Check for libraries
-AC_CHECK_LIB(c, iconv, [ LIB_ICONV=""; ],
- [ AC_CHECK_LIB(iconv, iconv, [ LIB_ICONV="-liconv"; LIBS="-liconv $LIBS" ],
- [echo "ERROR: Must have iconv routines."; exit 1])
- ])
-
-# Sablotron can depend on these libraries so include if present
-AC_CHECK_LIB(termcap, tgetnum)
-AC_CHECK_LIB(readline, readline)
-AC_CHECK_LIB(expat, XML_Parse)
-AC_CHECK_LIB(js, JS_NewContext)
-
-# Check for Sablotron
-AC_CHECK_LIB(sablot, SDOM_createElement, ,
- [echo "ERROR: Must install sablotron libraries."; exit 1])
-
# Checks for header files.
AC_FUNC_ALLOCA
AC_HEADER_STDC
@@ -106,5 +90,5 @@ AC_CHECK_TYPES(wstring, , , [
AC_CHECK_FUNCS([memset strchr strerror sprintf], ,
[echo "ERROR: Required function missing"; exit 1])
-AC_CONFIG_FILES([Makefile src/Makefile win32/Makefile])
+AC_CONFIG_FILES([Makefile src/Makefile win32/Makefile libs/Makefile])
AC_OUTPUT