summaryrefslogtreecommitdiff
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
index 3431b09..900e5a2 100644
--- a/plugin/Makefile.am
+++ b/plugin/Makefile.am
@@ -1,10 +1,26 @@
INCLUDES = -DCONF_PREFIX=\"$(sysconfdir)\"
-moduledir = $(prefix)/lib/sasl2/
+moduledir = $(libdir)
module_LTLIBRARIES = libdelegateldap.la
libdelegateldap_la_LDFLAGS = -module -avoid-version
libdelegateldap_la_SOURCES = delegateldap.c
+delegateldap.sasl: delegateldap.sasl.in Makefile
+ @sed -e "s|\@LIBDIR\@|$(libdir)|" $< > $@
+delegateldap.README: delegateldap.README.in Makefile
+ @sed -e "s|\@LIBDIR\@|$(libdir)|" $< > $@
+sasldir = $(libdir)/sasl2/
+sasl_DATA = \
+ delegateldap.sasl \
+ delegateldap.README
+
+EXTRA_DIST = \
+ delegateldap.sasl.in \
+ delegateldap.README.in
+
+CLEANFILES = \
+ delegateldap.sasl \
+ delegateldap.README