summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2008-06-07 20:36:27 +0000
committerStef Walter <stef@memberwebs.com>2008-06-07 20:36:27 +0000
commitabb82291887b6784a13a7fcf719fa1d463781007 (patch)
tree73975e8357db517f5b71818d107d665d92e8daa1 /tests/Makefile.am
Initial import
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..5372107
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,29 @@
+
+UNIT_TESTS =
+
+INCLUDES= \
+ -I$(top_srcdir) \
+ -I$(top_builddir)
+
+noinst_PROGRAMS= \
+ run-tests
+
+run-tests.c: $(UNIT_TESTS) prep-tests.sh Makefile.am
+ sh prep-tests.sh -b run-tests $(UNIT_TESTS)
+
+run_tests_SOURCES = \
+ run-tests.c \
+ run-tests.h \
+ $(UNIT_TESTS)
+
+EXTRA_DIST = \
+ prep-tests.sh \
+ cu-test \
+ test-helpers.c \
+ test-helpers.h
+
+# ------------------------------------------------------------------------------
+# Run the tests
+
+run: $(noinst_PROGRAMS)
+ ./run-tests