summaryrefslogtreecommitdiff
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
new file mode 100644
index 0000000..d1887a3
--- /dev/null
+++ b/plugin/Makefile.am
@@ -0,0 +1,13 @@
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -DSTRSET_CUSTMEM=1 \
+ -DDNS_NOTIFY_PATH=\"$(bindir)/notify-slaves\"
+
+lib_LTLIBRARIES = slapi-dnsnotify.la
+
+slapi_dnsnotify_la_SOURCES = \
+ slapi-dnsnotify.c
+
+slapi_dnsnotify_la_LDFLAGS = -module -avoid-version \
+ -export-symbols-regex 'plugin_init'