summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..19bbc50
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(PTHREAD_CFLAGS)
+
+bin_PROGRAMS = \
+ notify-slaves
+
+notify_slaves_SOURCES = \
+ notify-slaves.c \
+ ../common/async-resolver.c \
+ ../common/server-mainloop.c \
+ ../common/sock-any.c
+
+# TODO: Somehow PTHREAD_LIBS isn't setup on linux gcc
+notify_slaves_LDFLAGS = -pthread
+notify_slaves_LIBS = $(PTHREAD_LIBS) \ No newline at end of file