summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef <stef@ws.local>2004-03-31 04:04:16 +0000
committerStef <stef@ws.local>2004-03-31 04:04:16 +0000
commita4c0a06821a6f77ee1d7aebeb2eee02bb7aa913d (patch)
tree3de5c30f7fd9239c8db38fb1a5a8518064fa38b4 /configure.in
parent4d38570e69b996d6d119808c66460ceb4fe940b0 (diff)
Unix porting
Unix porting
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..f033a0c
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,43 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT(rtfm, 1.0, nielsen@memberwebs.com)
+AM_INIT_AUTOMAKE(rtfm, 1.0)
+
+LDFLAGS="$LDFLAGS -L/usr/local/lib"
+
+AC_LANG_CPLUSPLUS
+
+AC_CONFIG_SRCDIR([src/rtfm.cpp])
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+# Check for libraries
+AC_CHECK_LIB(sablot, SDOM_createElement, ,
+ [echo "ERROR: Must install sablotron libraries."; exit 1])
+
+# Checks for header files.
+AC_FUNC_ALLOCA
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stddef.h stdlib.h wchar.h assert.h stdio.h errno.h], ,
+ [echo "ERROR: Required C header missing"; exit 1])
+AC_CHECK_HEADERS([string exception stack], ,
+ [echo "ERROR: Required STL header missing"; exit 1])
+AC_CHECK_HEADERS([sablot.h sdom.h], ,
+ [echo "ERROR: Required Sablotron header missing"; exit 1])
+
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+# Required Functions
+AC_CHECK_FUNCS([memset strchr strerror swprintf], ,
+ [echo "ERROR: Required function missing"; exit 1])
+
+AC_CONFIG_FILES([Makefile src/Makefile win32/Makefile])
+AC_OUTPUT