summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2009-06-16 01:42:57 +0000
committerStef Walter <stef@memberwebs.com>2009-06-16 01:42:57 +0000
commit4c7bc1a52eb2b862fe7333d6f3b8dd40b581ab6e (patch)
tree70d95c0c0937bcbc76597c3a96d5a687f19da1fb /configure.in
parent26add004cb02a1ca5bc7bc76d798a3ea8c54ab37 (diff)
Fix IPV6 address parsing
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 59744e2..5d6417b 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,16 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_RANLIB
+# IPV6 enabled
+AC_ARG_ENABLE(ipv6,
+ AC_HELP_STRING([--disable-ipv6],
+ [Disable IPV6 support]))
+
+if test "$enable_ipv6" != "no"; then
+ AC_DEFINE_UNQUOTED(HAVE_INET6, 1, [Have IPV6 Support])
+ echo "enabling ipv6 support"
+fi
+
# TODO: Figure out why we need this wierd hack
ACX_PTHREAD( , [echo "ERROR: Pthread support not found."; exit 1] )