summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 59744e2..5d6417b 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,16 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_RANLIB
+# IPV6 enabled
+AC_ARG_ENABLE(ipv6,
+ AC_HELP_STRING([--disable-ipv6],
+ [Disable IPV6 support]))
+
+if test "$enable_ipv6" != "no"; then
+ AC_DEFINE_UNQUOTED(HAVE_INET6, 1, [Have IPV6 Support])
+ echo "enabling ipv6 support"
+fi
+
# TODO: Figure out why we need this wierd hack
ACX_PTHREAD( , [echo "ERROR: Pthread support not found."; exit 1] )